Jump to content
vandellan

Cmake 2.8

Recommended Posts

Hi,

 

I currently have cmake 2.6

 

However, the script I am trying to use with cmake requires 2.8

 

How do I install / upgrade to 2.8? Any help would be greatly appreciated.

  • Like 29

Share this post


Link to post
Share on other sites

As you're a CentOS user, look at using "yum", eg:

 

"yum update cmake"

 

(as root or a priv'd user)

  • Like 4

Share this post


Link to post
Share on other sites

Is this on CentOS 5? Is the system 32-bit (x86) or 64-bit (x86-64)?

 

It looks like we will either need to find a CMake 2.8 package from an additional software repository, as the version that CentOS 5 provides is too old, or we will have to install it ourselves from the CMake website.

 

Either way, I'm sure there will be a fix for this issue!

  • Like 2

Share this post


Link to post
Share on other sites

A "yum search make" should show all the "*make*" packages it can find.

 

If a specific verison is omitted from the output, then your repos don't have a later version.

 

One typical fix is to add another repo in so that the yum command does find the newer one, but I know CentOS can be a bit funny about using third-party stuff.

 

Post the output of that command up there and we'll see where we are then!

  • Like 1

Share this post


Link to post
Share on other sites

cmake is in the default centos repos. just yum install cmake:

 

cmake-gui.x86_64 : Qt GUI for cmake

cmake.x86_64 : Cross-platform make system

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...