Jump to content
Sign in to follow this  
square

IPv6 On Fedora Core 1

Recommended Posts

In my case, I am loading the IPv6 module.

 

[root@hostname root]# insmod ipv6
Using /lib/modules/2.4.22-1.2174.nptlsmp/kernel/net/ipv6/ipv6.o

 

This should work, and afaik the module should be there by default.

 

next, lets see if IPv6 module has loaded..

 

[root@xaser square]# ifconfig

eth0

Share this post


Link to post
Share on other sites
Guest voll

I can't get this to work.. whenever I run their client I get this:

 

[root@mobile bin]# ./tspc -vf tspc.conf
tspc - Tunnel Server Protocol Client

Loading configuration file

Connecting to server

Send request

Status code from server: 301 No more tunnels available
No ipv6 tunnel has been set (use -h for help)

Share this post


Link to post
Share on other sites

ATTENTION!!!

I've recieved a few reports of people having problems getting this error message..

 

Status code from server: 301 No more tunnels available

 

I think its a problem with Freenet6, i've emailed them about it and i'll post here when i know more..

 

Thanks..

 

Square

Share this post


Link to post
Share on other sites
Guest voll

Seems like freenet6 is up again :) Ran tspc again now, and it 'almost' worked.

 

Remembering that I'm behind a natting router, after editing tspc.conf again and putting my external IP-adress in the appropriate place ( client_v4=auto (change auto to your ip) ), it worked like a charm.

 

Only real problem now is that it's a little slow, but I can live with that for now :)

 

Thanks square for an excellent tutorial. This was the push I needed to actually try IPv6 out...

 

And if anyone out there who has gotten IPv6 to work wants to surf the net with it, you can append sixxs.org to the urls ( i.e www.google.com becomes www.google.com.sixxs.org ) and enjoy surfing the IPv6 wave... (Although I wouldn't login to anything using sixxs.org as a proxy ;) ).

Share this post


Link to post
Share on other sites

As far as I know only people with a ping latency below 100ms (to one of the POP's) are accepted by the Sixxs staff.

 

z0ny

Share this post


Link to post
Share on other sites
Guest mrlee

root@b-ill:/usr/local/tsp/bin# ./tspc -vf tspc.conf
tspc - Tunnel Setup Protocol Client v2.1.1
Initializing (use -h for help)


Connecting to server with reliable udp
Using TSP protocol version 2.0.0
Getting capabilities from server
Authenticating snowball
No common authentication mechanism found
Did you forget to specify a username?
Authentification error

Error is 7: AUTHENTIFICATION_ERROR
TSP session done
root@b-ill:/usr/local/tsp/bin#

 

i get this error, i've added my username and password. what is:

Authentification error

Error is 7: AUTHENTIFICATION_ERROR

?

 

anyone here who can help?

Share this post


Link to post
Share on other sites
Guest mrlee

hmm, i check the tspc.log and found this:

2004/11/26 12:46:36 tspc: tspMain: Connecting to server with reliable udp
2004/11/26 12:46:36 tspc: tspMain: Using TSP protocol version 2.0.0
2004/11/26 12:46:36 tspc: tspSetupTunnel: Getting capabilities from server
2004/11/26 12:46:38 tspc: tspSetupTunnel: Authenticating snowball
2004/11/26 12:46:39 tspc: tspSetupTunnel: Authentication success
2004/11/26 12:46:39 tspc: tspSetupTunnel: Asking for a tunnel
2004/11/26 12:46:39 tspc: tspExtractPayload: Processing response from server
2004/11/26 12:46:39 tspc: tspSetupTunnel: Got tunnel parameters from server, setting up local tunnel
2004/11/26 12:46:39 tspc: tspStartLocal: Going daemon, check tspc.log for tunnel creation status
2004/11/26 12:46:39 tspc: TunInit: Error opening device: /dev/net/tun
2004/11/26 12:46:39 tspc: TunInit: Try "modprobe tun"
2004/11/26 12:46:39 tspc: tspStartLocal: Waiting for setup script to complete
2004/11/26 12:46:39 tspc: tspStartLocal: Script failed to execute correctly
2004/11/26 12:46:39 tspc: tspMain: Error is 3: INTERFACE_SETUP_FAILED
2004/11/26 12:46:39 tspc: tspMain: TSP session done

 

i did:

root@b-ill:/usr/local/tsp/bin# modprobe tun
modprobe: Can't locate module tun
root@b-ill:/usr/local/tsp/bin#

 

where can i get this module? i run slackware10

 

mrlee

Share this post


Link to post
Share on other sites
Guest mrlee

i've added kernel-module-tun-1.1-4_2.2.24_6.2.3

./configure and make install. but i still cant modprobe tun

root@b-ill:/# modprobe tun
modprobe: Can't locate module tun
root@b-ill:/#

 

mrlee

Share this post


Link to post
Share on other sites
Guest mrlee

had to enable it in network devices -> tun/atp

 

now it's up working on slackware 10

 

thanks for good howto

 

mrlee

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...