Jump to content


We use cookies to log you in, for ads and for analytics. OK

Photo

Network controller: Intel Corporation PRO/Wireless 2200BG (rev 05)


  • Please log in to reply
1 reply to this topic

#1 anyweb

anyweb

    Administrator

  • Admin
  • PipPipPipPipPipPipPipPip
  • 3,692 posts

Posted 18 January 2006 - 10:11 PM

hi, first of all, this new distro is nice ! ESPECIALLY if you do

yum update

followed by

yum update

the new kernel and login screens are worth it. ok, once done you want to get your intel wireless to work don't you ? well it wont until you download the intel drivers from here or alternatively i'll post the driver/firmware and ieee crypt drivers in this post for your convenience (they were the ones I used). Unzip the attached file and in there you'll have the three tarballs namely


-rw-rw-r-- 1 anyweb anyweb 66280 Jan 18 13:22 ieee80211-1.1.9.tgz
-rw-rw-r-- 1 anyweb anyweb 125280 Jan 18 13:15 ipw2200-1.0.10.tgz
-rw-rw-r-- 1 anyweb anyweb 270419 Jan 18 13:17 ipw2200-fw-2.4.tgz

once done, read the INSTALL from intel, if you don't then don't blame me if you run into 'fatal errors' when trying to

modprobe ipw2200

I know that, because I did get those errors, so I RTFM'd and all was well after that.


In a nutshell what I had to do was:-

rmmod the three intel references in 'lsmod'

namely

rmmod ipw2200
rmmod ieee80211
rmmod ieee80211_crypt

once done, i tried to compile the ipw2200 driver, which errored out because it wanted the ieee stuff loaded first....

so i compiled that as follows...

make IEEE80211_INC=/usr/src/kernels/2.6.15-1.1858_FC5-i686/include/net/ieee80211.h

make install

and then back to the ipw2200 driver.

Once I got them working (took some time and lots of reading) I had to load the firmware. That was easy enough, just copied it to

/lib/firmware

Once done, I did

modprobe ipw2200

and it failed with a fatal error !!!! :(

it was at this time that i then re-read the INSTALL.txt file (renamed from INSTALL as the forums don't want a file with no extension).

in particular i did all three things here

1) Remove any old ieee80211 and ipw2200 driver modules from
/lib/modules/{VERSION}. Find them via:

% for i in ieee80211 ipw2200; do \
find /lib/modules/`uname -r` -iname ${i}*; done

Remove whatever that finds, including directories and .h files (create
backup files, unless you're feeling adventurous!).

Failure to remove old modules may result in unresolved symbols
when you try to load your new drivers.


2) Comment out or remove any CONFIG_IEEE80211 or CONFIG_IPW declarations
in kernel's autoconf.h. Find with:

% for i in IEEE80211 IPW; do \
grep CONFIG_${i} \
/lib/modules/`uname -r`/build/include/linux/autoconf.h; done

Use c-style comments (i.e. /* */) to comment out each line that it finds.
Use a pair of /* */ for each line separately, instead of trying to comment
out a block of several lines with a single pair of /* */.


3) Comment out or remove any CONFIG_IEEE80211 or CONFIG_IPW declarations
in kernel's .config. Find with:

% for i in IEEE80211 IPW; do \
grep CONFIG_${i} \
/lib/modules/`uname -r`/build/.config; done

Use shell-style comments (i.e. #) to comment out the entries it finds.

Failure to comment out these lines in steps 2) and 3) may affect the build
of your new module; settings in the ipw2200 Makefile are overridden by
settings in the kernel configuration.



8. BUILDING EXTERNAL (outside kernel source tree)




after all that ^^^^ :/ i recompiled the ieee bit, then re-compiled the intel driver and then did


modprobe ipw2200


and it worked ! no errors !

and not only that when I start neat now I get the intel wireless card listed whereas before it was nowhere to be seen, see attached screeshot !

cheers
anyweb

Attached Files


i do windows too

#2 PHiSQuaRE

PHiSQuaRE

    Noob

  • Members
  • Pip
  • 9 posts

Posted 19 February 2006 - 06:57 AM

...


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users