Jump to content


We use cookies to log you in, for ads and for analytics. OK

Photo

Debian Wireless


  • Please log in to reply
4 replies to this topic

#1 koby

koby

    Noob

  • Members
  • Pip
  • 7 posts

Posted 03 September 2008 - 07:31 PM

So I have Debian installed on my laptop, and I was able to get the madwifi driver working for my Atheros AR5008x (aka AR5418) So anywhere there it is sitting at ath0, but network manager the little dohicky up top doesn't want to play, there's only 3 options, wired network, configure something, and about, the wired network and the configure are greyed out, because I'm not connected(trying to use the wireless card) and it's not working,

I tried a few other apps to test out where the problem was, one even went as far to use my wireless card to scan for nearby networks, but I wasn't able to connect to them thru that program, anyway anyone know what I'm doing wrong?

#2 anyweb

anyweb

    Administrator

  • Admin
  • PipPipPipPipPipPipPipPip
  • 3,692 posts

Posted 04 September 2008 - 07:06 PM

if its working with madwifi isn't that enough ?
i do windows too

#3 koby

koby

    Noob

  • Members
  • Pip
  • 7 posts

Posted 07 September 2008 - 05:53 PM

if its working with madwifi isn't that enough ?


Well, I don't think I fully understand what your getting at, and I'm not completely sure how madwifi works with accessing a network.

#4 Gabriel03

Gabriel03

    Noob

  • Members
  • Pip
  • 3 posts

Posted 12 January 2012 - 09:40 AM

I put Debian 5, 64bit version on my laptop . I prefer Debian and want to use it. My problem is that I don't know what packages I need to install in order to get the wireless to work. I know my wireless devices on this machine work with Linux because they work fine under Knoppix. What packages do I need to install?? Should the kernel configuration already be fine the way it is, or do I need to configure and re-compile it to make all of my wireless networking operate correctly?
I want it to see th SSIDs that are broadcast, etc.

#5 Dungeon-Dave

Dungeon-Dave

    Linux-Noob Frequent Member

  • Moderator
  • PipPipPipPipPipPipPip
  • 972 posts

Posted 12 January 2012 - 11:27 AM

If you still have knoppix there, try the following commands:
dmesg
lsmod
Those should show diagnostic information as well as list which modules are loaded, and from there we should be able to identify what knoppix is using to get the card working.
From there, we can search for packages containing those modules and get them installed.

You shouldn't need to do any recompiling these days - using "apt" to download and install pre-compiled packages is much easier.
You may want to try the following commands (as an elevated account):
apt-get update
apt-get upgrade

Those should update your apt indexes and download any newer packages, some of which could get the card working.


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users