Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Access standalone network drive from Linux (Fedora 7)?

Quote:ok a quick look on my Fedora 8 box (this one) 

and I can see the following smb packages are installed


<blockquote data-ipsquote="" class="ipsQuote" data-ipsquote-contentapp="forums" data-ipsquote-contenttype="forums" data-ipsquote-contentid="3355" data-ipsquote-contentclass="forums_Topic"><div>pam_smbgnome-vfs2-smb




so if you are missing any of the above please install them and try again





To be safe, I tried to install each of those packages; but yum responded "xxxx is already Installed. Nothing to do" for each package.


I have made some progress, though... I discovered that file sharing was being blocked by the firewall on one of the Windows PCs. I enabled file sharing, and now when I browse the Windows network, I can see the workgroup. But trying to browse the workgroup results in a "The folder contents could not be displayed" dialog.


I tried disabling the Windows firewall, Linux firewall, and SPI firewall in the router (nothing like being wide open!) and could then browse the network.


Grrrr... so it looks like it probably is a firewall issue like you said in your first post. :-( I'm still not real sure what's going on. The only way I have successfully browsed is to shut down the Windows firewalls. But even doing that doesn't always result in successful browsing. And of course I can't leave the network wide ope like that, either.


Now I think I have all of the firewall issues resolved. I created at least one shared folder on each Windows computer on the network, and I have ensured that each Windows machine can access the shared folder(s) on each other machine, including this one when it boots under Windows instead of Linux.


I then uninstalled all of the samba packages on this machine, verified that /etc/samba/smb.conf was removed, and reinstalled the samba packages -- first using Applications->Add/Remove Software, then using sudo yum install for each of the packages listed above, just to be sure everything is installed.


But I still can't browse the network. Using Applications->System Tools->File Browser, I can see the workgroup, but double clicking on it yields "The folder contents could not be displayed."


Using Gnome Commander, when I select SMB I can see the Workgroup, but selecting it yields "timeout reached."


Using Applications->Accessories->Smb4K, I can see the computers, and the shared directory on one computer. But I can't see any files in that directory, nor the shared directories of any other computers.


Any ideas?


I'm definitely a newbie to Linux, and especially to samba. Am I overlooking something obvious (like configuration, security settings, etc.)?

hi are you trying to browse these shares using a username/password that is the SAME on both the windows box and the linux box ?

Quote:hi are you trying to browse these shares using a username/password that is the SAME on both the windows box and the linux box ?

Yes. Although I don't think it should matter since the Windows shares are all set for "everyone."


I seem to have made some progress, though. I tried pinging every machine, and found that I could ping them via IP address, but not with the computer name. A couple of google searches led me to add the computer to the /etc/hosts file. Now I can ping it by computer name, and more importantly, can browse the shares.


However, adding all of the computers to the /etc/hosts file means that I would need to switch every computer to use fixed IP addresses so that their address is known. (Currently, I'm using the DHCP server on the router to assign IP addresses). Is there a better way? Or is using fixed IP addresses the "proper" thing to do?


Thanks in advance for your help!


Forum Jump:

Users browsing this thread: 1 Guest(s)