Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trouble playing certain videos with mplayer(codec issue)

Hello I have a problem i'm trying to sort out. I have suse 10 and I use mplayer to play my videos. Most play fine but there are certain disks I have that simply don't work even tho I have the win32codec pack installed on my system. I'm kinda lost as to what to do next so any help would be appreciated. When I run the file which is either an mpeg or a .avi I get an audi codec error and garbage shown in the screen. If I run mplayer from the console I get the output below.




RAWDV file format detected.

VIDEO: [DVSD] 720x480 24bpp 29.970 fps 0.0 kbps ( 0.0 kbyte/s)


Opening audio decoder: [libdv] Raw DV Audio Decoder

Unknown/missing audio format -> no sound

ADecoder init failed :(

Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders

Cannot find codec 'dvaudio' in libavcodec...

ADecoder init failed :(

ADecoder init failed :(

Cannot find codec for audio format 0x56444152.

Read DOCS/HTML/en/codecs.html!


vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)


Opening video decoder: [dshow] DirectShow video codecs

Decoder supports the following YUV formats: YUY2 UYVY

Decoder is capable of YUV output (flags 0x9)

VDec: vo config request - 720 x 480 (preferred csp: Packed YUY2)

[PP] Using codec's postprocessing, max q = 4.

VDec: using Packed YUY2 as output csp (no 0)

Movie-Aspect is undefined - no prescaling applied.

VO: [xv] 720x480 => 720x480 Packed YUY2

Selected video codec: [qdv] vfm:dshow (Sony Digital Video (DV))


Audio: no sound

Starting playback...

No bind found for key MOUSE_BTN0

V: 61.0 1830/1830 58% 7% 0.0% 0 0


what types of media are you trying to play that are causing these issues ? DVD's ?


how did you install the win32 codecs ?






Hello Anyweb Thanks for replying.

. I installed the win32codec pack full a long time ago through yast, and the source is the site packman. I can play most any other media, it's just 2 collection of movies that don't work. THey are .avi and .mpeg.

It's 2 seasons of star trek that don't play for some reason. They played in windows when I burned them but in linux I get the codec error. So I know the files play.




Get the restricted formats at



Forum Jump:

Users browsing this thread: 1 Guest(s)