Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Zero sized reply error (squid ?)

hi guys


anytime i try to reply to a PM from someone on this forum i get an error (after 10 or so seconds)


Quote:ERRORThe requested URL could not be retrieved


While trying to retrieve the URL: [/url][url=<___base_url___>/index.php][/url][url=<___base_url___>/index.php]


The following error was encountered:


* Zero Sized Reply


Squid did not receive any data for this request.


Your cache administrator is webmaster.

Generated Mon, 31 Oct 2005 07:56:18 GMT by smoothwall (squid/2.5.STABLE9)

this is very annoying for me and dam hard to troubleshoot,. so i'm asking if any of you can help me with troubleshooting it.


i've read this [/url][url=]



Quote:11.51 Why do I sometimes get ``Zero Sized Reply''? 

This happens when Squid makes a TCP connection to an origin server, but for some reason, the connection is closed before Squid reads any data. Depending on various factors, Squid may be able to retry the request again. If you see the ``Zero Sized Reply'' error message, it means that Squid was unable to retry, or that all retry attempts also failed.


What causes a connection to close prematurely? It could be a number of things, including:


1. An overloaded origin server.

2. TCP implementation/interoperability bugs.

3. Race conditions with HTTP persistent connections.

4. Buggy or misconfigured NAT boxes, firewalls, and load-balancers.

5. Denial of service attacks.


You may be able to use tcpdump to track down and observe the problem.


Some users believe the problem is caused by very large cookies. One user reports that his Zero Sized Reply problem went away when he told Internet Explorer to not accept third-party cookies.


Here are some things you can try to reduce the occurance of the Zero Sized Reply error:


1. Delete or rename your cookie file and configure your browser to prompt you before accepting any new cookies.

2. Disable HTTP persistent connections with the server_persistent_connections and client_persistent_connections directives.

3. Disable any advanced TCP features on the Squid system. Disable ECN on Linux with echo 0 > /proc/sys/net/ipv4/tcp_ecn/.


If this error causes serious problems for you, Squid developers would be happy to help you uncover the problem. However, we will require high-quality debugging information from you, such as tcpdump output, server IP addresses, operating system versions, and access.log entries with full HTTP headers.


If you want to make Squid give the Zero Sized error on demand, you can use the short C program below. Simply compile and start the program on a system that doesn't already have a server running on port 80. Then try to connect to this fake server through Squid:


#include <stdio.h>

#include <stdlib.h>

#include <unistd.h>

#include <sys/types.h>

#include <sys/socket.h>

#include <netinet/in.h>

#include <arpa/inet.h>

#include <assert.h>



main(int a, char **B)


struct sockaddr_in S;

int s,t,x;

s = socket(PF_INET, SOCK_STREAM, 0);

assert(s > 0);

memset(&S, '\0', sizeof(S));

S.sin_family = AF_INET;

S.sin_port = htons(80);

x = bind(s, (struct sockaddr *) &S, sizeof(S));

assert(x == 0);

x = listen(s, 10);

assert(x == 0);

while (1) {

struct sockaddr_in F;

int fl = sizeof(F);

t = accept(s, (struct sockaddr *) &F, &fl);

fprintf(stderr, "accpeted FD %d from %s:%d\n",

t, inet_ntoa(F.sin_addr), (int)ntohs(F.sin_port));


fprintf(stderr, "closed FD %d\n", t);


return 0;


and i guess this refers to squid itself ? and not the forums httpd ?


i'm using two squids here, one is smoothwall 3.0 alpha protecting (and it produces the exact same error as a previous smothwall 2.0 on different hardware) and on another network i have yet another smoothwall box.


i've tried disabling squid on this connection but when i 'reply' to a pm instead of getting the 'zero sized reply' error, the message never moves on to the 'sent' screen, it just 'stays where it is' after i press 'send message'


so something is wrong, but what ? any ideas ?????


facts to note:


the webserver has been upgraded completely (new os (fedora core 4) new apache, new php, new mysql, new invision power board, different hardware), the smoothwall protecting the webserver has been upgraded completely (both hardware and software)


so in other words i dont think this is a hardware issue, but a software one, and i'm having a very hard time finding out what is wrong....




Quote:hi guys 

anytime i try to reply to a PM from someone on this forum i get an error (after 10 or so seconds)

Yeah, you must have been trying to PM me recently because I have the same first reply you sent come through loads of times. You can email me - I've PMed you the address.


once i get the time to do something with your review i will, sorry for the delay in responding.


in terms of my zero sized reply errors, does anyone have a clue where i should start looking to troubleshoot as it is causing two issues for me


1. causing registering members to not get registered (due to errors...)

2. making personal messaging on the site prone to failure...





the solution was to change my smoothwalls hostname, it contained an illegal character "_"


so I had given it a hostname called "firewall_1"


changing that to "firewall1" resolved the issue.




you can delete my account too... :P

Forum Jump:

Users browsing this thread: 1 Guest(s)