Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
using vnc to control the :0 display

So, i finally figured out a very useful solution to a dilema i've been having for years.


Now, normally when you use vncserver. you cant control the :0 display, which is the display that actually shows on your monitor. little did i know, theres actually a library built into XFree86 AND xorg. makes life so much simpler.. as well, solves a second problem i had,


what ever method i used, whether it be kde desktop sharing, or xf0rb or whatever it was called. I found they used 100% processor power and were really laggy.


problem solved!

xorg has it built in. with a very simple setup...


i'm using fedora core 3. and all i had to do was.. edit /etc/X11/xorg.conf and toss in a

Load "vnc"

into the 'Section "Module"' of xorg.conf,

and in the "Screen" section, toss in

'Option "passwordFile" "/root/.vnc/passwd"'


restarted x, and boom works..


I got this information from [/url][url=]


Enjoy. any questions on this simple task, join up irc efnet #linux-noob and i can give ya a hand.. its VERY simple to do. and uses almost no processor power.



nice! Thanks for sharing.

there is also x11vnc that acts like a windows vncserver for X




This is the bees knees :-)

I had been using VNC over a ssh connection from a windows machine for a while but even over my broadband connection (750/256) it was painfully slow. This has now brough it up to a speed where it is usefull, and when I get home at night I can still use the account using the :0 display.

Thanks for this, its great.


I couldn't get this working on gentoo.


I am currently following the instructions on


Just got it working :):)!


What a difference from the normal slow slow cpu-eater!




Has anybody got this to work in Fedora Core 6. I have used this before and it worked great but now in FC6 I don't have a "modules" section in my xorg.conf file

Any suiggestions ???

Thanks in advance,



Quote:Has anybody got this to work in Fedora Core 6. I have used this before and it worked great but now in FC6 I don't have a "modules" section in my xorg.conf file. Any suggestions ???

When there is a section missing from the xorg.conf then the system will probe or use its defaults. Therefore the modules section just needs to be build from the default.


This is an example of mine (however I am not running Fedora!).

Section "Module"
Load        "dbe"
Load        "type1"
Load        "freetype"


This load dbe, type1 and freetype. Obviously you would add the Load for vnc too.


here's the module section from /etc/X11/xorg.conf from my FCR5 box incase you need it.


Section "Module"
    Load  "dbe"
    Load  "extmod"
    Load  "fbdevhw"
    Load  "glx"
    Load  "record"
    Load  "freetype"
    Load  "type1"
    Load  "dri"


I feel like a bity of a fool. I have been playing around with the GUI (most of the stuff I do on my Fedora box is CLI work !!) and there is a setting in System -> Preferences -> Remote Desktop that allows people to connect to the current desktop using VNC. DOH!!

I am also in the process of evaluating FreeNX as an alternative, apparently its faster than VNC over a ssh connection.


Forum Jump:

Users browsing this thread: 1 Guest(s)