Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
input/output error during read on /dev/hda

Howdy, and happy new year! :)


I'm trying to install Fedora Core 3 and when i choose Autmatically partition in Disk Partitioning Setup i get "The partition table on device hda was undreadable. To create new partitions it must be initialized, causing the loss of ALL DATA on this drive. This operation will override any previous installtion choises about which drives to ignore. Would you like to initialize this drive, erasing ALL DATA?".

And when I click yes, I get this: "input/output error during read on /dev/hda".


The computer is like a 5-6 years old Intel P2 350 Mhz, 128 MB RAM, 6 GB HDD.


Anyone know what the problem might be?

Not sure what the problem is offhand. Have you tried fdisk? Try manually partitioning your disk then try the installation again.

How do i set up the partitions in fdisk?

From what I know it can only format to FAT32.

fdisk doesn't actually format anything, it just writes the partition table. That aside you should have access to a minimal shell from the boot cd - perhaps in rescue mode? - and can fdisk from there. If not, you can always download a boot floppy from Slack or some other distro, boot with that, write your partition table, then reboot with the FC install disc.

So I could just go fdisk in the command prompt and make a partition?

Or what do you mean? What's a partition table?


Think I got you now. :)

I tried to do fdisk from rescue shell but it said "unable to read /dev/hda/". :(


if you make a partition and you want it linux then make the partition and then do this mkfs.ext3

this will format the partition to extention 3


This sounds like bad news. When was the last time you actually used this drive? It sounds like the drive itself might be toast. Can you post the output of dmesg? dd?



Actually, "dmesg | grep hda" would be better. Don't need all the other junk.



Quote:Think I got you now. :)I tried to do fdisk from rescue shell but it said "unable to read /dev/hda/". :(
What was the "final" disposition of this issue? I'm having the exact same problem. :/


ok.. this sound like another windows crap..


basically if you have a fat16 , fat32, ntfs, basically anything fs from microsoft...

chances are that you may simply need to clean up teh disk, using scandisk or chkdsk... i have this issue alot..with dirty windows partitions...


might not work for you.. but worked for me so i suggest it..


Forum Jump:

Users browsing this thread: 1 Guest(s)