Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
UserDir - kept getting 403 Forbidden



My apache works fine for /var/www/html. so i want to make UserDir, /home/*/public_html


userdir mod.


<IfModule mod_userdir.c>
   # UserDir is disabled by default since it can confirm the presence
   # of a username on the system (depending on home directory
   # permissions).
   UserDir "enabled *"
   UserDir "disabled root"

   # To enable requests to /~user/ to serve the user's public_html
   # directory, use this directive instead of "UserDir disable":
   UserDir public_html





<Directory "/home/*/public_html">
       Options Indexes Includes FollowSymLinks
       AllowOverride None
       Allow from all
       Order deny,allow

<Directory "/home/*/public_html/cgi-bin">
       Options ExecCGI
       SetHandler cgi-script


public_html's chmod are: 775


it still Forbidden 403. is there is anything i must've missed out? or it need to change something?


it would be appreciate if you could help me out.


chmod 711 /home/user


by default RH has the home dir's chmod to 700 and the apache user needs at least --x access to get into and dirs about the public_html dir


ahh of course, i'm idiot! lol. i chmod the public_html as 755. but it had to chmod on home dir...


thanks mate! :)


Forum Jump:

Users browsing this thread: 2 Guest(s)