Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Linux Slide Show

Quote:Anyway, I'll keep you posted on the progress. I may reinstall slackware yet again to see if I can get rid of some packages I don't need. Unless someone can tell me how to remove packages without reinstalling.

hey congrats Zane, you've worked hard on this.. and im glad its starting to pay off for you. you can manage slackware packages with these commands: installpkg, upgradepkg, removepkg... also checkout pkgtool... however most of the slack users have suggested swaret as the best utility to use for package management.


Check out..




Problems Problems...


I resized all my images to be 800x600 or smaller. That worked pretty well except...


1. Every now and then I get a screen without an image. The screen is usually black but sometimes a darkish orange, blue, or purple. After the alotted time the next image comes up fine. Verbose mode shows that it isn't always doing this on the same images. Redo the command and the image comes up fine. Not a huge deal since I don't mind having a blank screen every now and then. Just annoying since there appears to be no reason for this.


2. I let the slideshow run for an hour or two and every thing locks up with a black screen showing. Hitting Q to quit out doesn't free things up. Cntrl-Alt-Fx doesn't switch terminals. Only thing that seems to work is Cntrl-Alt-Del. Haven't put it on a network yet and tried ssh yet though. If I can get in that way I might be able to kill whatever the offending piece of code is. Note: I've disabled power down after however many minutes in the bios and I've setterm -blank 0 to keep the monitor from blacking out. Still have this stupid problem I can't explain.


Some progress:


Ok... I still get the problem of sometimes a solid colored screen shows instead of the image. Weird...


As for the second problem I did this...


setterm -blank 0 -powersave off -powerdown 0


I also added these lines to libsvga.config



VesaSave 14


I don't know if this had any effect but what the hey...


Ok... doesn't lock up after long periods of time. But MONITOR still GOES BLACK!!! I hit a key and I'm right back to the slideshow. But I have to hit a key. I don't get it.


I've shut off all powersaving options in the bios. And the setterm command I'm using should shut off the rest right? What am I missing?


After a whole day slideshow was still running but display would turn itself off.


I rebooted and checked the bios again. Somehow display autooff was back on. Silly me. So I'm testing again. We'll see. But I'm optomistic. Left to be done.


1. Figure out how to run seejpeg not as root. (setuid but I don't know how to do it) I'm sure I'll figure it out.


2. More difficult, boot up and go directly in an run seejpeg without hitting a login screen. I've been reading on this for some time. I still don't understand it. This is also why I chose not to go with zgv, you HAVE to be logged in to run it according to the documentaiton. Also still need Cntrl-alt-F2 to go to login screen for when I want to put more pictures on the system.


3. Figure out how to get pics of USB jump drive. Woops I did that. Works GRAND!!! :-)


4. Test with external mouse and keyboard as that I'm going to be getting rid of the built in ones.


5. Figure out how to make boot up go faster stops on updating module dependancies or something. No reason for it to stop there I'm not even hooked to the network.


6. Reinstall from scratch to prove I can duplicate and to make system as lean as possible.


7. Tear laptop appart begin work on picture frame to mount it in.


this is an interesting project


please post some photos of the result :)





I'll be happy to. If I ever finish... New problems galore.


Ok I'm looking into how to automatically start seejpeg on login without getting a login...


Looks like I can simply change one line in /etc/inittab to...


1:2345:respawn:/sbin/mingetty --autologin <user> tty1


Easy enough. except I'm using slackware which doesn't have mingetty.


So off I go to find mingetty and get it installed. Done change the line...


Try it... all it does is make it so I don't have to type in the user name, I still have to type in the password. Turns out I need something called "PAM". Well I'm out of time today. Probably be saturday before I get more time. Groan.


Once I get the autologin working hopefully I'll be set. I'm working on an auto mount script that greps the /proc/bus/usb/devices for anything that is storage and then beeps, mounts said storage, copies all image files to /pics folder, unmounts storage, and double beeps to let me know it's done. I figure I would run it in a cron job checking every 1 to 2 seconds for the device or is there a better way to do this?





Forum Jump:

Users browsing this thread: 1 Guest(s)